Codeup 6116.最短距离

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7
#include <stdio.h>
int main()
{
    int n,i,total=0;
    scanf("%d",&n);
    int load[n];
    for (i=0;i<n;i++)
    {
        scanf("%d",&load[i]);
        total+=load[i];        //环形路,计算总距离
    }
    int m,start,end;
    scanf("%d",&m);
    for (i=0;i<m;i++)
    {
        int num1=0,num2=0;
        scanf("%d %d",&start,&end);
        int max=start>end?start:end;    //找到输入的大的和小的路口
        int min=start<end?start:end;
        int x=max-min;                 //计算正向走几段路
        while (x)
        {
            num1+=load[min-1];   //计算正向的走的距离
            min++;
            x--;
        }
        num2=total-num1;   //反向的距离
        int final=num1<num2?num1:num2;  //更短的距离
        printf("%d\n",final);
    }
    return 0;
}

 

运行截图: