poj 1328 Radar Installation——贪心+区间选择

转载于:https://blog.csdn.net/baymax__dabai/article/details/89340332?utm_medium=distribute.pc_relevant.none-task-blog-BlogCommendFromMachineLearnPai2-1.add_param_isCf&depth_1-utm_source=distribute.pc_relevant.none-task-blog-BlogCommendFromMachineLearnPai2-1.add_param_isCfios

Radar Installation

Descriptionc++

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.web

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.ide

在这里插入图片描述

Inputsvg

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.spa

The input is terminated by a line containing pair of zeros
Output.net

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Inputcode

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Outputxml

Case 1: 2
Case 2: 1

题目大意: 以x轴为海岸线,上方为海,下方为陆地,海岸上的点表示雷达,海里的点表示岛屿,雷达的扫描区域为一个以该雷达为圆心半径为d的圆,问最少装多少个雷达能够使每一个岛屿都被扫描到。blog

作题思路: 可将问题转化为:求最少用多少个点能够使x轴上每一个区间内都有一个点。

而且当y>d时,该岛屿没有知足的雷达。

在这里插入图片描述

c++ AC 代码

#include<cmath>
#include<cstring>
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

double compute(double d,double y)
{
    double r = d*d-y*y;
    return sqrt(r);
}

struct Range
{
    double right,left;
};
Range range[1005];

bool cmp(const Range& a,const Range& b)
{
    return a.right < b.right;
}

int main()
{
    int n,t=0;
    double d,x,y;
    while(scanf("%d%lf",&n,&d) && (n || d))
    {
        bool flag=0; // 记录是否有不知足的点
        //memset(range,0,sizeof(range)); 不用这个程序运行更快

        for(int i=0;i<n;i++)		// 输入数据并算出每一个岛屿的雷达范围
        {
            scanf("%lf%lf",&x,&y);
            if(y>d) flag = 1;
            double xi = compute(d,y);
            range[i].left = x-xi;
            range[i].right = x+xi;
        }

        if(flag)
        {
            printf("Case %d: -1\n",++t);
            continue;
        }

        sort(range,range+n,cmp);	// 按照右侧半径的范围排序
        int pos=0,num=1;
        for(int i=1;i<n;i++)		// 遍历全部区间
        {
            if(range[i].left <= range[pos].right) continue;
            else
            {
                ++num;
                pos = i;
            }
        }
        printf("Case %d: %d\n",++t,num);
    }
    return 0;
}